Resovling AM_ICONV undefined error when building osxfuse

I got this issue when building osxfuse code:

 
wum@osxfuse$ ./build.sh -t lib
OSXFUSEBuildTool()            : supported platforms: 10.7 10.8
OSXFUSEBuildTool(lib)         : initiating Universal build for 10.7
OSXFUSEBuildTool(lib)         : configuring library source
Running libtoolize…
Running autoreconf…
configure.in:82: warning: macro `AM_ICONV' not found in library
glibtoolize: putting auxiliary files in `.'.
glibtoolize: copying file `./ltmain.sh'
glibtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in and
glibtoolize: rerunning glibtoolize, to keep the correct libtool macros in-tree.
glibtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
configure.in:82: warning: macro `AM_ICONV' not found in library
configure.in:82: error: possibly undefined macro: AM_ICONV
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1
Linking kernel header file…
To compile run './configure', and then 'make'.
configure: error: cannot find install-sh or install.sh in "." "./.." "./../.."
OSXFUSEBuildTool(lib) failed: cannot configure OSXFUSE library source for compilation.
 
I soon googled and find that I was short of the get text library. However installing the library with homebrew didn't help. I try other workarounds but they didn't appear to work.
 
The major problem is that AM_ICONV (used in some automate script) is defined in iconv.m4
 
Soon I realized if there's an issue in the include path. autoconf/glibtoolize is searching the m4 file in /usr/share/aclocal, but gettext's m4 file was installed to /opt/local/share/aclocal/ by my homebrew. I copied all the m4 files from /opt/local/share/aclocal/ to /usr/share/aclocal, and everything was resolved…
 
此条目发表在 Mac OSX & iOS, 技术 分类目录。将固定链接加入收藏夹。